Extract files to your preferred path

  1. Extract the .zip file
  2. Start PADS Layout
  3. Select File > Library
  4. Browse to your preferred library from the drop-down menu, or create a new library if you wish

To import the symbol

  1. Select the CAE Decals option
  2. Click Import... and browse to the extracted folder and select the .c library file

To import the footprint

  1. Select the PCB Decals option
  2. Click Import... and browse to the extracted folder and select the .d library file

To import the part

  1. Select the Parts option
  2. Click Import... and browse to the extracted folder and select the .p library file

How to Link a 3D STEP file to a footprint in PADS layout

  1. Import the footprint and part linkage file (*.d and *.p)
  2. Place the footprint on a PCB (Via netlist import or ECO mode)
  3. Open the 3D viewer by going to View > PADS 3D
  4. Right click on the footprint and select Edit Decal
  5. Because the 3D viewer is open, a window will pop up titled 'Align 3D Models.' Under "Parts mapped to selected model" select the part you just added to the board
  6. Click Import and navigate to the STEP file
  7. Adjust alignments as necessary
  8. Go to File > Exit Decal Editor to go back to the board view
Did this answer your question?