Note: Most Altium CircuitStudio files are saved in the native format .intLib. However, you may occasionally run into cases where they're saved as .lia. After unzipping the file, check the extension of the file you downloaded and follow the relevant instructions below.

For Native format (.intlib):

  1. Double-click the downloaded .intlib file or drag & drop the downloaded .intlib file into the CircuitStudio window.

  2. A pop-up window will appear. You have two choices: Extract Sources or Install Library.

    Extract Sources:

    This will allow you to open the library into the Projects window as an Integrated Library project.

    Install Library:

    With this option, the library will be installed and added to your Libraries Panel.

For P-CAD format (.lia):

  1. Go to File > New Project > Integrated Library

  2. Go to File > Import, and choose P-CAD Libraries

  3. Select the file downloaded from SnapEDA and click Open

  4. Click on Save in the pop-up notification

Did this answer your question?