You can get a DXF file from Eagle, please follow these steps:

  1. Open Eagle.
  2. Go to File > New > Board.

     3. Click Edit > Add..

     4. Place the footprint in the board layout.
     5. Make sure that the Pad and Cream layers are displayed.

     6. Go to File > Export > DXF
     7. Edit the file location and/or name the file.
     8. You can decide whether to check or not “Fill areas” and “Use wire widths” based on what you need.

          9. Click OK.

Did this answer your question?