To integrate Orcad schematics to Allegro PCB:

  1. Open Orcad Capture.
  2. Create a new schematic design by clicking File>New>Design or open your current schematic design by clicking File>Open>Design.
  3. Add symbols into your library by following our import guide here.
  4. To place symbols into your schematic go to your schematic design tab(*.dsn), click Place Part, click Add library, and navigate to your *.olb file.
  5. Once you have your schematic design finished, go to your project tab(*.opj), click the (+) button beside your *.dsn file, click the (+) to SCHEMATIC1 folder then click your schematic design, then click Tools>Create netlist.
  6. The netlist window will appear, under PCB Editor tab, under Options, determine the path where you want to save your netlist by clicking the 3 dots(…) under Netlist Files Directory, click OK.

    **IMPORTANT:
    I suggest saving it to all in one folder where all your .olb, .dra, .pad and .psm are located.**
     
  7. Open Allegro PCB Designer.
  8. Go to Setup>User Preferences.
  9. Go to Paths>Library>Click the 3 dots (…) on the padpath row
  10. Add the path where your folder with the *.pad files are saved, click OK.
  11. Click the 3 dots (…) on the psmpath row.
  12. Add the path where your folder with the *.psm files are saved, click OK
  13. After setting up the paths needed, click OK.
  14. Go to File>Import>Logic
  15. The import logic window will appear. Under Import logic type, select Design entry CIS.
  16. Click the 3 dots (…) on the Import directory and select the path of the folder where you saved your netlist, click OK.
  17. Click Import Cadence.
  18. Wait until successful import.
  19. Now go to Place>Manually. The Placement window will show.

You will see all the parts from your schematics there. Select all the check boxes of those parts then place them on your board.

Did this answer your question?